use old url after repo moved to repo group

Tamas Csabina's Avatar

Tamas Csabina

15 Jun, 2018 02:17 PM

Dear Support,

We just did some reorganization of some repositories and moved them (around 100) under a repository group. Now the access url of these repos have been changed (from http://server\repo to http://server\repo_group\repo).
Is there a way to make the old url still working? We are using CI tools where these url are configured, and of course the individual clones on developer PCs are also have a broken url now.

We know about the http://server\_ID url, but we haven't used that at the first place.

Thanks and regards,
Tamas Csabina

We are using Rhodecode CE 4.7.2.

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 15 Jun, 2018 02:27 PM

    Marcin Kuzminski's Avatar

    Hi,

    Unfortunately we don't have that functionality. the _ID was desinged to give permanent urls. However it's a simple fix on http server, simply generate the names of repos and write 100 redirects so old urls will point to the new ones. It's much faster than changing CI/end user configs.

  2. 2 Posted by Tamas Csabina on 15 Jun, 2018 03:04 PM

    Tamas Csabina's Avatar

    Hi Marcin,

    Thanks for the super fast reply.
    I am trying to figure out what http server Rhodecode is using. (I just took over the Rhodecode administration role).
    I have found an apace instance running, but stopping it doesn't seems to bring down Rhodecode. So I am a bit confused...
    This is an ubuntu server...

    Could you give some directions?

    Regards,
    Tamas

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 15 Jun, 2018 03:12 PM

    Marcin Kuzminski's Avatar

    What is the clone url? If it has a port inside, maybe rhodecode is accessed directly without an HTTP server.

    Or it's using NGINX.

    In case here are the example configs:
    https://docs.rhodecode.com/RhodeCode-Enterprise/admin/nginx-config-...

    https://docs.rhodecode.com/RhodeCode-Enterprise/admin/apache-conf-e...

    P.s please consider upgrading to latest version ASAP, because of important security fixes we fixed recently

  4. 4 Posted by Tamas Csabina on 15 Jun, 2018 03:27 PM

    Tamas Csabina's Avatar

    http://<server>/rhodecode/embedded/<project>

    Before the move it was:
    http://<server>/rhodecode/<project>

    "maybe rhodecode is accessed directly without an HTTP server."
    Could you elaborate on this, please? This very much might be the case...
    No nginx installed.
    Apache2 is installed, but if I stop it, I can still access Rhodecode.

    Does Rhodecode has it's own web server kind of thing? How can we access it without a webserver?
    And if that is the case, probably the suggested solution to create redirects for the old urls is not an option, does it?

    Regards,
    Tamas

  5. Support Staff 5 Posted by Marcin Kuzminsk... on 15 Jun, 2018 03:39 PM

    Marcin Kuzminski's Avatar

    Yes rhodecode has it's own HTTP server, so role of Apache/Nginx is a reverse proxy into rhodecode http server. Mostly for SSL purposes.

    does <server> in your case have a port after colon e.g http://my-organization:8000/repo_name ?

    If that was the case, you can do some other tricks, e.g configure apache to listen on port 8000 and change rhodecode to listen on other port, so you intercept connections

  6. 6 Posted by Tamas Csabina on 15 Jun, 2018 04:59 PM

    Tamas Csabina's Avatar

    Apache listens on 8080.
    There is no port in the <server> url. just the FQDN of the server.

  7. Support Staff 7 Posted by Marcin Kuzminsk... on 15 Jun, 2018 05:01 PM

    Marcin Kuzminski's Avatar

    Ok that is a better situation, i think this might be an DNS setup, cannot help with that really, but there must be something resolving the FQDN into running rhodecode server.

    Once you find it it would be simple to redirect it to Apache/Nginx and then reverse proxy it to RhodeCode. Rewrite of urls would then work as expected.

  8. 8 Posted by Tamas Csabina on 15 Jun, 2018 05:05 PM

    Tamas Csabina's Avatar

    Hi Marcin,

    Thanks again for sticking with me!

    Indeed there is another Apache server running as proxy, responsible to translate the FQDN to the IP of the rhodecode server.
    So now the idea is that the redirection should be modified, not to talk to rhodecode directly, but to the apache server (on port 8080). And configure the apache server on the rhodecode server to redirect these old urls to the new variant?

  9. Support Staff 9 Posted by Marcin Kuzminsk... on 15 Jun, 2018 05:08 PM

    Marcin Kuzminski's Avatar

    I believe all can be done at the Apache instance that is responsible for the proxying requests to RhodeCode, simple catch the list of url names and redirect them to the new schema

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

18 Sep, 2018 03:30 PM
17 Sep, 2018 02:08 PM
11 Sep, 2018 09:12 AM
11 Sep, 2018 08:12 AM
06 Sep, 2018 05:38 AM