Index setup problem

Mark's Avatar

Mark

19 May, 2017 06:14 PM

Hi,

I've setup a fresh install of Community Edition and am trying to validate the index function. When running rhodecode-index --instance-name=community-1, i'm getting the following error: API KEY invalid or, has bad role for an API call

Any clues? I believe I've setup everything in a similar fashion to another instance we've been testing against and the function works properly there. What did I miss?

Thanks.

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 19 May, 2017 08:14 PM

    Marcin Kuzminski's Avatar

    Please make sure inside ~/.rhoderc community-1 uses an auth-token with API role, if not you can create a new one under your account auth tokens.

    Best,

  2. 2 Posted by Mark on 19 May, 2017 08:29 PM

    Mark's Avatar

    That was it. I was mistakenly using the 'Generated feed token'. I've generated a new token specifically for 'api calls' and testing looks good. Thanks for the quick and accurate response.

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 19 May, 2017 09:55 PM

    Marcin Kuzminski's Avatar

    Hi Mark,

    Great it was resolved quick.

    P.S. Please consider joining our Slack community channel under https://rhodecode.com/join . Get access to our development team as well as community members always willing to help.

  4. Marcin Kuzminski closed this discussion on 19 May, 2017 09:55 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Nov, 2017 03:02 PM
21 Nov, 2017 06:38 PM
03 Oct, 2017 08:26 PM
03 Oct, 2017 05:48 PM
28 Sep, 2017 05:55 PM