URL not opening

dkanagaraj's Avatar


17 Apr, 2017 12:39 PM

Installed rhodecode community version and ensured all services are started. but url <ipaddress:10001> is not opening.

ipaddress sample: 10.x.y.z

1. Tried after adding 10001, 10000 port in firewall exception list
2. Tried after disabling selinux
3. Tried after disabling firewall.

But nothing helped. Can someone put a light on this.

Provided the required outputs and versions from my machine.

[devops@localhost ~]$ rccontrol status

 - NAME: community-1
 - VERSION: 4.7.1 Community
 - VCS: vcsserver-1
 - URL:
 - CONFIG: /home/devops/.rccontrol/community-1/rhodecode.ini

 - NAME: vcsserver-1
 - VERSION: 4.7.1 VCSServer
 - URL:
 - CONFIG: /home/devops/.rccontrol/vcsserver-1/vcsserver.ini

[devops@localhost ~]$ sestatus
SELinux status: disabled

[devops@localhost ~]$ sudo systemctl status firewalld
[sudo] password for devops:
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Sun 2017-04-16 18:35:54 EDT; 5min ago
 Main PID: 609 (code=exited, status=0/SUCCESS)

Apr 16 18:23:41 localhost.localdomain systemd[1]: Starting firewalld - dynamic firewall daemon...
Apr 16 18:23:42 localhost.localdomain systemd[1]: Started firewalld - dynamic firewall daemon.
Apr 16 18:35:53 localhost.localdomain systemd[1]: Stopping firewalld - dynamic firewall daemon...
Apr 16 18:35:54 localhost.localdomain systemd[1]: Stopped firewalld - dynamic firewall daemon.

[devops@localhost ~]$ mysql --version
mysql Ver 15.1 Distrib 5.5.52-MariaDB, for Linux (x86_64) using readline 5.1

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 18 Apr, 2017 11:15 AM

    Marcin Kuzminski's Avatar


    This is becuase your instance is serving on a local ip, you can change it to inside rhodecode.ini then it would work. However we recommend leaving it at and using a NGINX or Apache as a reverse proxy, so you can benefit from SSL.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac


17 Oct, 2018 03:22 PM
15 Oct, 2018 05:20 AM
03 Oct, 2018 01:16 PM
01 Oct, 2018 08:41 AM
28 Sep, 2018 10:12 AM
26 Sep, 2018 04:34 AM