Installation on Raspberry Pi

Ho Yin's Avatar

Ho Yin

22 Jan, 2017 04:58 AM

When trying to run the RhodeCode Control Installer on a Raspberry Pi 3, it fails with this message:

ERROR: Platform you are running on armv7l-linux is not supported.

My old private server died and that was running 2.2.x which I remember worked on the Pi. I figured that now would be a good chance to try upgrading, but if it's not possible, I'm willing to just not upgrade and continue using that old version. The only problem is that all of the old install links for the installer scripts and RhodeCode are dead. Is there anything I can do at this point?

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 22 Jan, 2017 09:33 PM

    Marcin Kuzminski's Avatar

    Hi,

    please try our installer with --ignore-platform-check flag, it might be that i'd simply work. Another alterntive is to run it from source as rhodecode is now open source again.

    Please check code.rhodecode.com/rhodecode-enterprise-ce in case the flag doesn't work.

  2. 2 Posted by Ho Yin on 23 Jan, 2017 02:47 AM

    Ho Yin's Avatar

    Thanks for the quick reply Marcin. The flag almost worked. It got to 90% but threw this error:

    EXCEPTION: OSError(8, 'Exec format error')

    I'll poke around the logs (attached) and see if I can figure out how to run it from source. At worst, I'll chalk this up to being unable to run on a Raspberry Pi and look into buying a cheap x86 server.

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 24 Jan, 2017 07:08 PM

    Marcin Kuzminski's Avatar

    Yes, it might be that the error is becuase of lacking NIX support for ARM. I think the only reason is to try to run it from source.

    P.S. Please consider joining our Slack community channel under https://rhodecode.com/join . Get access to our development team as well as community members always willing to help.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

 

03 Oct, 2017 08:26 PM
03 Oct, 2017 05:48 PM
28 Sep, 2017 05:55 PM
25 Sep, 2017 06:06 PM
25 Sep, 2017 05:54 AM
18 Aug, 2017 09:19 PM