RhodeCode Installer 2.2.3 Connection error!

Ahmad Samir's Avatar

Ahmad Samir

08 Dec, 2016 04:11 PM

Hello Guys,

I've an issue with my RhodeCode on Ubuntu 16.04 , it doesn't start and gives me : ImportError: No module named datetime.
Okay, I decided to reinstall the RhodeCode after suitable installation for almost 3 years.
When I tried to update the software , it gives me error :

... running command: su repo -s /bin/sh -c 'cp "/home/repo/rhodecode/data/production.ini" "/home/repo/rhodecode/data/production.ini.2.2.3"'
Connection error!

I've tried many and many solutions with no clue.
Can you please help me updating current RhodeCode or even start the current version?

Regards,
Ahmad

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 08 Dec, 2016 04:20 PM

    Marcin Kuzminski's Avatar

    Hi Ahmad,

    We introduced a totally new installer a while ago. Here you can find the docs on how to upgrade from 2.X series.

    https://docs.rhodecode.com/RhodeCode-Control/tasks/upgrade-from-2x....

  2. 2 Posted by Ahmad Samir on 08 Dec, 2016 06:03 PM

    Ahmad Samir's Avatar

    Hello Marcin,

    That was super awesome , you saved my life mate.
    Thanks a lot.
    Now, I can load my RhodeCode Enterprise 4.5.1 Enterprise, but it's stuck with RhodeCode License Key.
    How can I get a License Key ???

    Thanks in advance mate.
    Regards,
    Ahmad

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 08 Dec, 2016 06:13 PM

    Marcin Kuzminski's Avatar

    Hi,

    Happy to hear you migrated easily.

    Enterprise is our commercial version. It's paid. We however released an open source community edition that is absolutely free.

    Please check here how to switch your EE edition into CE.

    https://docs.rhodecode.com/RhodeCode-Control/tasks/switch-editions.html

    Sent from TypeApp ​

  4. 4 Posted by Ahmad Samir on 08 Dec, 2016 06:21 PM

    Ahmad Samir's Avatar

    Hello ,

    I can hardly express my gratitude man. You made it piece of cake.
    Thanks again.
    Regards,
    Ahmad

  5. Marcin Kuzminski closed this discussion on 12 Dec, 2016 10:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac