Internal Server Error when open rhodecode

Xinyan's Avatar

Xinyan

15 Oct, 2016 03:15 PM

Hi guys,

I'm have been using rhodecode for a couple of days, but yesturday I couldn't open rhodecode while I could still push and pull code. The logs are the following:

[2016-10-15 22:58:55 +0000] [3049] [ERROR] Error handling request /
Traceback (most recent call last):
  File "/opt/rhodecode/store/rnklx8i8kclsz24q0nbfd959f9nlz1m8-python2.7-gunicorn-19.6.0/lib/python2.7/site-packages/gunicorn/workers/sync.py", line 135, in handle
    self.handle_request(listener, req, client, addr)
  File "/opt/rhodecode/store/rnklx8i8kclsz24q0nbfd959f9nlz1m8-python2.7-gunicorn-19.6.0/lib/python2.7/site-packages/gunicorn/workers/sync.py", line 176, in handle_request
    respiter = self.wsgi(environ, resp.start_response)
  File "/opt/rhodecode/store/zdz5m20x9vhlp3ibbq14l95mcshhja3l-python2.7-rhodecode-enterprise-ce-4.4.1/lib/python2.7/site-packages/rhodecode/config/middleware.py", line 395, in pyramid_app_with_cleanup
    return pyramid_app(environ, start_response)
  File "/opt/rhodecode/store/zdz5m20x9vhlp3ibbq14l95mcshhja3l-python2.7-rhodecode-enterprise-ce-4.4.1/lib/python2.7/site-packages/rhodecode/config/middleware.py", line 83, in __call__
    environ, start_response)
  File "/opt/rhodecode/store/i1ax7221bg9k9c9fd3pv3mrlnsvxc11f-python2.7-Routes-1.13/lib/python2.7/site-packages/routes/middleware.py", line 131, in __call__
    response = self.app(environ, start_response)
  File "/opt/rhodecode/store/zdz5m20x9vhlp3ibbq14l95mcshhja3l-python2.7-rhodecode-enterprise-ce-4.4.1/lib/python2.7/site-packages/rhodecode/lib/middleware/https_fixup.py", line 46, in __call__
    return self.application(environ, custom_start_response)
  File "/opt/rhodecode/store/incd2pyifnx1i11anwh308gxp16rp957-python2.7-pyramid-1.6.1/lib/python2.7/site-packages/pyramid/router.py", line 223, in __call__
    response = self.invoke_subrequest(request, use_tweens=True)
  File "/opt/rhodecode/store/incd2pyifnx1i11anwh308gxp16rp957-python2.7-pyramid-1.6.1/lib/python2.7/site-packages/pyramid/router.py", line 198, in invoke_subrequest
    response = handle_request(request)
  File "/opt/rhodecode/store/zdz5m20x9vhlp3ibbq14l95mcshhja3l-python2.7-rhodecode-enterprise-ce-4.4.1/lib/python2.7/site-packages/rhodecode/tweens.py", line 62, in pylons_compatibility_tween
    auth_user = get_auth_user(environ)
  File "/opt/rhodecode/store/zdz5m20x9vhlp3ibbq14l95mcshhja3l-python2.7-rhodecode-enterprise-ce-4.4.1/lib/python2.7/site-packages/rhodecode/lib/base.py", line 386, in get_auth_user
    cookie_store = CookieStoreWrapper(session.get('rhodecode_user'))
  File "/opt/rhodecode/store/miwpp0jyk99zbccj6vzwv4axjayp41cs-python2.7-Paste-2.0.2/lib/python2.7/site-packages/paste/registry.py", line 137, in __getattr__
    return getattr(self._current_obj(), attr)
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/session.py", line 663, in __getattr__
    return getattr(self._session(), attr)
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/session.py", line 659, in _session
    **params)
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/session.py", line 162, in __init__
    self.load()
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/session.py", line 329, in load
    self.namespace.acquire_read_lock()
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/container.py", line 206, in acquire_read_lock
    self.open('r', checkcount=True)
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/container.py", line 238, in open
    self.do_open(flags, replace)
  File "/opt/rhodecode/store/l7bv0fc6pv8fmmgmdbh39hzn4iskq3hj-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/container.py", line 663, in do_open
    self.hash = pickle.load(fh)
EOFError

Can anyone give me some advise? Thank you very much!

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 15 Oct, 2016 03:33 PM

    Marcin Kuzminski's Avatar

    This looks like problem with sessions. Is everything al right with your filesystem ?
    Maybe some permissions issues, or the storage where sessions are data/sessions is somehow damaged ?

    Alternatively inside rhodecode.ini you could switch to DB based sessions instead of file based ones...

  2. 2 Posted by Xinyan on 15 Oct, 2016 03:41 PM

    Xinyan's Avatar

    Hi Marcin,

    Yes, there was no storage left for a while, but I've cleared my server and everything is right except rhodecode. I've tried to restart the server and the problem still exists. Is there anything I need to do to recover rhodecode?

    Thanks

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 15 Oct, 2016 03:44 PM

    Marcin Kuzminski's Avatar

    Hi,

    i think the session files could get damaged, simply remove session folder

    ~/.rccontrol/enterprise-1/data/sessions

  4. 4 Posted by Xinyan on 15 Oct, 2016 03:47 PM

    Xinyan's Avatar

    It works now, thank you very much!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Nov, 2017 03:02 PM
21 Nov, 2017 06:38 PM
03 Oct, 2017 08:26 PM
03 Oct, 2017 05:48 PM
28 Sep, 2017 05:55 PM