Rhodecode and Mercurial Subrepositories

Sebastian's Avatar

Sebastian

16 Oct, 2013 03:03 PM

Dear Sirs,

I tried to use Mercurial Subrepositories with Rhodecode and ran into some problems.

I tried this:
hg clone http://0.0.0.0:5000/mainrepo
cd mainrepo
hg init subrepo
echo subrepo = subrepo > .hgsub
hg add .hgsub
hg commit

When I want to "hg push" this error is showing up:
Übertrage Unterarchiv subrepo zu http://0.0.0.0:5000/mainrepo/subrepo
Abbruch: HTTP Error 404: Not Found

Thanks for any help!
Greetings Sebastian

  1. Support Staff 1 Posted by Marcin Kuzminsk... on 16 Oct, 2013 05:09 PM

    Marcin Kuzminski's Avatar

    Hi,

    did you seen this docs regarding our support of Mercurial Subrepos: https://rhodecode.com/docs/usage/subrepos.html ?

    Please try this, and let us know how that works for you.

    Cheers

  2. 2 Posted by Sebastian on 22 Oct, 2013 01:08 PM

    Sebastian's Avatar

    Yes, I did the steps in the howto you mentioned also.

    My first try (described in my first post) was to init a subrepository.
    My second try was that howto, to init a remotesubrepository.

    Here after this steps:
    hg clone http://0.0.0.0:5000/mainrepo
    cd mainrepo
    hg clone http://0.0.0.0:5000/remotesubrepo
    echo "remotesubrepo = http://0.0.0.0:5000/remotesubrepo" > .hgsub
    hg add .hgsub
    hg commit -m "XX"
    hg push

    Until here it works. But then a clone of http://0.0.0.0:5000/mainrepo/remotesubrepo is rejected with HTTP Error 404: Not Found.

    All in all I tried to clone a subrepo via http://0.0.0.0:5000/mainrepo/subrepo or a remotesubrepo via http://0.0.0.0:5000/mainrepo/remotesubrepo ....... it seems that this is not possible :-(

  3. Support Staff 3 Posted by Marcin Kuzminsk... on 30 Oct, 2013 04:27 PM

    Marcin Kuzminski's Avatar

    I think it's not since an url: mainrepo/remotesubrepo would indicate a group structure, you would have to clone /remotesubrepo directly.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac